Dismiss Notice
Hi Guest, stickers are available from our online store.

1.4 TSI shuddering idle

Discussion in 'Leon Mk2 (2006-2012)' started by Haci Altin, Jul 14, 2019.

  1. Haci Altin

    Joined:
    Jul 14, 2019
    Messages:
    2
    Likes Received:
    0
    Hey guys and girls, new here.

    Recently I bought a 1.4 TSI 2010 with 121,000 miles on the clock all seemed well just a few faults with the car but it was a very good price.

    When I came back I realised while idling the car shudders whether the engine is warm or cold. Also when pulling away in 1st gear at low revs while the clutch is still engaged the engine feels a little rough too. Apart from that the car feels like it pulls as it should through all the gears.

    I've had the car fully serviced. Recently the the lambda sensor (bank 1) gave a fault code reading 'too rich' so my mechanic advised to get it changed but the shuddering still persisted.
    I contacted a mechanic online and he said it most likely needs the inlet valves cleaned (walnut blasting).

    Any idea what it may be? The engine light is back on after a 60 mile motorway journey but the car still feels the same and no different noises. I ordered an OBD tool so I can scan it without taking it to my mechanic, should be here in a few hours.

    Thank you
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice