Dismiss Notice
Hi Guest. If you're not subscribing to us on YouTube yet, you're missing out on car news and reviews. Subscribe to our channel to get notified when we post new videos.

16795 VAG-COM Fault Code

Discussion in 'Ibiza Mk3 (2000-2002)' started by Big_Lad, Feb 15, 2007.

Tags:
  1. Big_Lad

    Joined:
    Jul 10, 2001
    Messages:
    972
    Likes Received:
    0
    Now I know there are some VAG-COM guru's / geeks (delete as appropriate) among us and was wondering if you guys could pass on some of your wisdom in helping me overcome this code which has reared its ugly head again on my ECU

    16795 P0411 Secondary Air Injection System: Incorrect Flow Detected.

    After a bit of reading through SCN and on Google, it has been suggested that I check my MAF settings :confused: as well as hoses and what not.

    I have VAG-COM and (borrowed) cable so if logs are needed to understand what is going on then i will "log" them tonight and post up.

    Still a bit of a newbie to the software, but want to learn it

    Any help is appreciated guys.

    Ta
     
  2. Dan Cupra R

    Dan Cupra R The Yellow Sub

    Joined:
    May 2, 2006
    Messages:
    1,514
    Likes Received:
    0
    Might be something to do with the air filter? Do u have an aftermarket one fitted?

    Is the secondry air pipe disconectted? I had something similar on mine and seat said cos Ive fitted a dynatwist it will throw up a code.
     
  3. Big_Lad

    Joined:
    Jul 10, 2001
    Messages:
    972
    Likes Received:
    0
    Nope, i still have the standard one fitted.

    Excuse my ignorance, but where is the secondary air pipe connected?
     
  4. acidstrato

    acidstrato My Fast says shut up!

    Joined:
    Dec 9, 2004
    Messages:
    5,942
    Likes Received:
    0
    the black plastic hose that connects to the air box


    its one of those codes that dont make much sense, i get it occasionally (my code says leak detected) but iv gone through the whole system and there are no leaks or owt. however ages ago i found the secondary air injection pump hanging down from its bracket (underneath the engine) i believed it had been smacked on a few speed bumps
     
    #4 acidstrato, Feb 15, 2007
    Last edited: Feb 15, 2007
  5. Dan Cupra R

    Dan Cupra R The Yellow Sub

    Joined:
    May 2, 2006
    Messages:
    1,514
    Likes Received:
    0
    If you were to blank the end of the secondary pipe or remove it altogether would that stop any codes from appearing?

    Has anyone tried that?

    When I start the car first thing I can hear the pipe sucking and making a 'vacuum' sound. This happens for about 5 mins and the car idles at about 1.1k .

    After 5 mins its stops and then the car idles around 0.8 - 0.9 on the revs
     
  6. acidstrato

    acidstrato My Fast says shut up!

    Joined:
    Dec 9, 2004
    Messages:
    5,942
    Likes Received:
    0
    you couldn't really block it off as that could damage the pump, a few people have successfully removed it though however it remains to be seen if it stops any codes appearing. it might even cause a fault it self
     
  7. cupragaz

    cupragaz Full Member

    Joined:
    Aug 25, 2002
    Messages:
    93
    Likes Received:
    0
    i've had this fault a few times before at work , i'd check ur secondary air pump (next to oil filter) itself as they do like to split around the sides and leak, they arent cheap to replace either approx £280
     
  8. h17och

    h17och the hunt is over. 460bhp

    Joined:
    Sep 1, 2005
    Messages:
    3,504
    Likes Received:
    1
    it will be the vaccum pipe going to the secondary valve, it always throws this code!

    replace the vaccum pipe...job done!!

    ive removed mine and im getting deleted from my ecu so i get no codes!!

    HoocH
     
  9. Big_Lad

    Joined:
    Jul 10, 2001
    Messages:
    972
    Likes Received:
    0
    I'll have a look at lunchtime today to see if its loose / split or in bad shape.

    £280 eh? Thats a bit steep!
     
  10. cupragaz

    cupragaz Full Member

    Joined:
    Aug 25, 2002
    Messages:
    93
    Likes Received:
    0
    yeah i know mate i was shock when i found out how much they were
     
  11. gavthelad

    gavthelad Bring on the Boooooost

    Joined:
    Nov 19, 2005
    Messages:
    1,393
    Likes Received:
    0
    when the codes are present in your ecu from removing the secondary air system, does this effect any performance or revert back to safe settings at all as im looking to de-clutter my bay.
     
  12. h17och

    h17och the hunt is over. 460bhp

    Joined:
    Sep 1, 2005
    Messages:
    3,504
    Likes Received:
    1
    all the pump does it blow air to the cat! its not gonna cause probs if your cat doesnt warm up as fast...just means it takes longer to become effective

    HoocH
     
  13. h17och

    h17och the hunt is over. 460bhp

    Joined:
    Sep 1, 2005
    Messages:
    3,504
    Likes Received:
    1
    i have a pump if you need it but check that vaccum hose to the valve on the head 1st...its normally that!!
     
  14. gavthelad

    gavthelad Bring on the Boooooost

    Joined:
    Nov 19, 2005
    Messages:
    1,393
    Likes Received:
    0
    So what happens to the fault code then? does it just sit there patiently awaiting attention? I know you said your having your secondary air deleted from your ecu but is it gonna show the annoying management light on the dash until its deleted?
     
  15. acidstrato

    acidstrato My Fast says shut up!

    Joined:
    Dec 9, 2004
    Messages:
    5,942
    Likes Received:
    0
    i THINK some of the lads just stuck a resistor into the plug so it keeps the voltage and doesn't realise the system has been removed
     
  16. Big_Lad

    Joined:
    Jul 10, 2001
    Messages:
    972
    Likes Received:
    0
    Got a picture Hooch???....Bit of a novice on engines me :redface:

    This is the first opportunity i've had to look at the car since i started this thread.
     
  17. h17och

    h17och the hunt is over. 460bhp

    Joined:
    Sep 1, 2005
    Messages:
    3,504
    Likes Received:
    1
    ive not got the 2ndry system to take a pic so if you find a engine bay pic i will show you where to look
     
  18. Big_Lad

    Joined:
    Jul 10, 2001
    Messages:
    972
    Likes Received:
    0
    My - rather filthy - engine bay.

    :hide:

    [​IMG]
     
  19. h17och

    h17och the hunt is over. 460bhp

    Joined:
    Sep 1, 2005
    Messages:
    3,504
    Likes Received:
    1
    take the cover off

    then follow the big pipe from the airbox down towards the turbo.

    as it starts to bend down look to the left of it, there will be either rusty or shiney disc! (some rust some dont) that is the top of the valve

    look over the valve...there will be a vaccum hose to it...replace it

    HoocH
     
  20. Big_Lad

    Joined:
    Jul 10, 2001
    Messages:
    972
    Likes Received:
    0
    Ok i've followed said pipe down and can't see anythingm my torch isn't the greatest i'll admit so i'll have a look tomorrow in the daylight.

    Failing that i'll nab one of the guys from the Bedford meet on Wednesday and get them to have a look.

    [​IMG]
     
    #20 Big_Lad, Feb 19, 2007
    Last edited: Feb 20, 2007

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice