Dismiss Notice
Hi Guest. If you're not subscribing to us on YouTube yet, you're missing out on car news and reviews. Subscribe to our channel to get notified when we post new videos.

Advice wanted on 2008 leon k1 keeps throwing throttle body fault

Discussion in 'Leon Mk2 (2006-2012)' started by mnmraine, Jun 16, 2014.

  1. mnmraine

    mnmraine Active Member

    Joined:
    Jun 16, 2014
    Messages:
    43
    Likes Received:
    0
    Also to mention mine is faulting even when parked, I had the codes reset drive it less than 5 miles and left it on the drive, went to start it next day and faults were there the second I out the ignition on


    Sent from my iPhone using Tapatalk
     
  2. IbizaAlex

    IbizaAlex AKS tuning

    Joined:
    May 11, 2008
    Messages:
    532
    Likes Received:
    0
    Could also be coil packs.
     
  3. JamesLCR

    Joined:
    Jan 3, 2014
    Messages:
    593
    Likes Received:
    0
    coil packs expensive to fix mate? I heard could also be spark plugs

    Sent from my SM-N9005 using Tapatalk
     
  4. mnmraine

    mnmraine Active Member

    Joined:
    Jun 16, 2014
    Messages:
    43
    Likes Received:
    0
    Well I've finally given in and booked the car into seat for it to be fixed, fingers crossed it gets fixed and not cost me a bomb, technician thinks it could be throttle body wiring loom as they currently have one in with the same problem, will keep updated of fault


    Sent from my iPhone using Tapatalk
     
  5. cheungy

    Joined:
    May 25, 2008
    Messages:
    1,919
    Likes Received:
    0
    Hey there,

    Can you confirm the part number of the brand new throttle body used? or where it was purchased from?

    I had the same fault like TFSI MIKE and ALEX... but we all used the latest revision throttle bodies and been fine ever since (mine was 2nd hand but made sure it was the latest one!)

    The latest one now ends with 06F133062(T) instead (Q)

    The older ones will have VDO on them but the newer ones will have CONTINENTAL (stamped)

    VW has also got a fix on the wiring too, like a TPS (forgot what they call them but there is a wiring fix too something to do about bad earthing)
     
    #45 cheungy, Jun 24, 2014
    Last edited: Jun 24, 2014
  6. MARK@CMBAUTOS

    MARK@CMBAUTOS Active Member

    Joined:
    Jul 1, 2014
    Messages:
    4
    Likes Received:
    0
    The Fault code's are
    005445-throttle valve controller p1545-001-malfunction-intermittent

    005476-throttle actuator (j338) p1564-002-under-voltage during basic setting-intermittent

    U can clear both these codes and they re apear apon the ignition being turned on without the car being started:censored:
    All codes have been taken Via vag com
     
    #46 MARK@CMBAUTOS, Jul 1, 2014
    Last edited: Jul 1, 2014
  7. mnmraine

    mnmraine Active Member

    Joined:
    Jun 16, 2014
    Messages:
    43
    Likes Received:
    0
    Lol cheers, any ideas on what's causing it yet


    Sent from my iPhone using Tapatalk
     
  8. MARK@CMBAUTOS

    MARK@CMBAUTOS Active Member

    Joined:
    Jul 1, 2014
    Messages:
    4
    Likes Received:
    0
    it states (under voltage during basic setting) i belive this is when the throttle body self adjusts before start up ??
    could it be battery voltage ??? the battery looks and tests ok also starts the car and charges fine buts its not an OE battery its an exide battery
    iv seen aftermarket batterys have the wrong starting amps etc and cause major managment issues
    buts that wasnt on a seat
     
    #48 MARK@CMBAUTOS, Jul 1, 2014
    Last edited: Jul 1, 2014
  9. MARK@CMBAUTOS

    MARK@CMBAUTOS Active Member

    Joined:
    Jul 1, 2014
    Messages:
    4
    Likes Received:
    0
    autodata even states battery :shrug:
    17972 ,P1564 Throttle control unit - voltage low during basic setting /causes/ Battery, wiring
     
  10. cheungy

    Joined:
    May 25, 2008
    Messages:
    1,919
    Likes Received:
    0
    I had the same codes on my Leon, Latest REVISION Throttle Body swapped and problems went away! ;)
     
  11. MARK@CMBAUTOS

    MARK@CMBAUTOS Active Member

    Joined:
    Jul 1, 2014
    Messages:
    4
    Likes Received:
    0
    the car has a new one fitted but im unsure the part number as i never fitted it :cry:
     
  12. cheungy

    Joined:
    May 25, 2008
    Messages:
    1,919
    Likes Received:
    0
    I'm wondering if its a older revision even tho its a brand new part... Seems like the only cure is to have the latest one either Q or T on the End from my post earlier.

    VCDS or Vag-Com should be able to de-tech the part-number?
     
  13. JamesLCR

    Joined:
    Jan 3, 2014
    Messages:
    593
    Likes Received:
    0
    I bought a direct replacement for my throttle body. Codes get kicked up every so often. Is this a certain cure for it? Might just buy it again and fit it. Wasn't that hard last time I done it
     
  14. JamesLCR

    Joined:
    Jan 3, 2014
    Messages:
    593
    Likes Received:
    0
    Right I'm going to buy the throttle body for my car. The one that ends in a cue. But would a CDN engine code work on my BWA engine?
     
  15. JamesLCR

    Joined:
    Jan 3, 2014
    Messages:
    593
    Likes Received:
    0
    Could the turbo waste gate cause these codes? My car seems to making a whooshing noise at 3000rpm
     
  16. mnmraine

    mnmraine Active Member

    Joined:
    Jun 16, 2014
    Messages:
    43
    Likes Received:
    0
    It could be faulty wiring as seat have one in with the same problem at the mo, we thought a new battery would sort it had the wrong battery but faults came up again yesterday so I'm now thinking it needs a new throttle body wiring loom but it's off to seat Monday, hopefully get some answers and the throttle body fitted is a continental one :-( can't wait to actually drive the car for more than 20 miles before it faults as I'm starting to lose all interest in it.


    Sent from my iPhone using Tapatalk
     
  17. lukey K1

    lukey K1 K1 owner

    Joined:
    Oct 25, 2014
    Messages:
    29
    Likes Received:
    0
    Sorry to bring an old thread up but ive just had the EPC light and engine management light come on could this be related to the throttle body as i currently havent got the cash to trial and error this issue, mines a tfsi 08 plate

    Cheers
     
  18. mnmraine

    mnmraine Active Member

    Joined:
    Jun 16, 2014
    Messages:
    43
    Likes Received:
    0
    I would get a diagnostics on it, I learnt the hard way of trying different things even with diagnostics and got pissed off with spending money after money and still having the same problem that I ended up sending it to seat and having to get a new ecu and remap overall cost me £4000 to fix it.
     
  19. lukey K1

    lukey K1 K1 owner

    Joined:
    Oct 25, 2014
    Messages:
    29
    Likes Received:
    0
    Ive just out a thread up just run diagnotics n this was the code


    08852 - Fuel Pressure Regulator Valve (n276) open circuit P2294 No signal/No communication intermitten.


    Not sure what it means though lol
     
  20. mnmraine

    mnmraine Active Member

    Joined:
    Jun 16, 2014
    Messages:
    43
    Likes Received:
    0
    No idea, they are different codes to what mine had could be a problem with throttle body wiring loom. Best to speak to a mechanic and give them the codes they should be able to help you
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice