Dismiss Notice
Hi Guest, stickers are available from our online store.

AFS Error

Discussion in 'Leon Mk2 (2006-2012)' started by PaulusB, Oct 10, 2019.

  1. PaulusB

    PaulusB Active Member

    Joined:
    Jun 9, 2019
    Messages:
    102
    Likes Received:
    24
    Hello I got the following error.

    [​IMG]

    I have read many topics about this problem I replaced the front levelling sensor and checked the wiring. The error stayed away for one day.

    This fault code only appears with heavy rain during 2 days. Short period off rain no problems. This was the same issue with the old sensor. I checked the rubber inside the wheel weld for the wire and this sits ok.

    Does somebody know where to look? The light on the dash and the ping is driving me crazy.

    In the afs module it self?
    [​IMG]

    The ballast under the headlight have no fault code and when it dry the do there upside dance on start.




    Verstuurd vanaf mijn SM-G930F met Tapatalk
     
  2. PaulusB

    PaulusB Active Member

    Joined:
    Jun 9, 2019
    Messages:
    102
    Likes Received:
    24
    I did a scan with vcds

    Software Coding: 2555909
    Work Shop Code: WSC 06403 785 00200
    Additional Info: 7L6941329A AFS-Lst.-Modul l 0002
    7L6941329A AFS-Lst.-Modul r 0002
    VCID: 326A2254AD2F60D64C-8066
    Fault Codes have been Erased

    2 Faults Found:
    00496 - Sensor for Vehicle Leveling; Front
    010 - Open or Short to Plus - MIL ON
    Freeze Frame:
    Fault Status: 11101010
    Fault Priority: 3
    Fault Frequency: 1
    Reset counter: 146
    Mileage: 188552 km
    Time Indication: 0
    Date: 2000.00.00
    Time: 20:33:56

    Freeze Frame:
    Voltage: 11.93 V
    Speed: 0.0 km/h
    ABS 1

    01539 - Headlights Not Adjusted
    005 - No or Incorrect Basic Setting / Adaptation - MIL ON
    Freeze Frame:
    Fault Status: 11100101
    Fault Priority: 2
    Fault Frequency: 1
    Reset counter: 146
    Time Indication: 0

    Freeze Frame:
    Invalid
    Invalid
    Invalid


    Than I looked at al signals and indeed front sensor no signal

    [​IMG]

    When u enter the security code and try to perform a basis setting alignment I fails because its missing the front sensor signal. So group 001 is missing.

    [​IMG]

    Can somebody tell me where I can find the controller in the car with code 5M0907357A (2007) I ordered a used revision one with number 5M0907357C (2010) is this part interchangeable? When I coded it.


    Verstuurd vanaf mijn SM-G930F met Tapatalk
     
  3. PaulusB

    PaulusB Active Member

    Joined:
    Jun 9, 2019
    Messages:
    102
    Likes Received:
    24
    Zo fixed the problem I bought I used 2010 afs module with revision letter C from a mark 6 golf.

    I swapped it and swapped the original coding then did a basic headlight adjustment in vcds and boom all the errors where gone.

    I opened the old but cannot see anything wrong on the soldering. Maybe its in the chip.

    Whatever its fixed for 15 euro.[​IMG][​IMG][​IMG][​IMG][​IMG]

    Verstuurd vanaf mijn SM-G930F met Tapatalk
     
    #3 PaulusB, Oct 15, 2019
    Last edited: Oct 15, 2019

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice