Dismiss Notice
Hi Guest. If you're not subscribing to us on YouTube yet, you're missing out on car news and reviews. Subscribe to our channel to get notified when we post new videos.

Altea XL 1.9 TDI lacking power - it is as though the turbo isn't doing much

Discussion in 'Altea - includes XL and Freetrack' started by MarkTDI, Apr 8, 2018.

  1. MarkTDI

    MarkTDI Active Member

    Joined:
    Feb 19, 2018
    Messages:
    17
    Likes Received:
    3
    I have a problem with a 2007 Altea XL 1.9 TDI with about 137K miles on the clock.

    It is a BXE engine, I know how bad they can be but this one still has conrods intact :)

    It is as flat as a fart. Ok when around town but no go for overtaking or up steep hills.

    it is as though the turbo isn't doing much ?

    We also have a newer 2010 Altea XL with the same 1.9TDI 105 engine and that goes really well so I have something to compare to.

    Can anyone suggest any simple checks to prove if the turbo is working at all.

    I have a Carista dongle and various apps etc, what should I be looking for?

    Runs nice and smooth for a high miles TDI as it has had oil changes every 9K since new.

    It just lacks get up and go.

    Any clues anyone ?

    Thanks,

    Mark.
     
  2. teeth2k

    teeth2k Full Member

    Joined:
    Feb 8, 2003
    Messages:
    908
    Likes Received:
    0
    Vcds first port of call
     
  3. teeth2k

    teeth2k Full Member

    Joined:
    Feb 8, 2003
    Messages:
    908
    Likes Received:
    0
    Also look for split boost pipes
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice