Dismiss Notice
Hi Guest. If you're not subscribing to us on YouTube yet, you're missing out on car news and reviews. Subscribe to our channel to get notified when we post new videos.

annoying engine rev issue

Discussion in 'Ibiza Mk4 (2002-2008)' started by rich3001, May 26, 2010.

  1. rich3001

    rich3001 Active Member

    Joined:
    Mar 9, 2009
    Messages:
    137
    Likes Received:
    1
    Ok so yesterday my car had the engine managment light come on so i turned the car off then back on and it had cleared, the car now has a vibration when its left ticking over could that be engine mounts? any way il get back on track now this morning when i came to a set of lights it seemed like it took about 10 seconds for the revvs to even consided dropping as it held around the 2500 mark, it also does this on all gear changes and when i turn the car off too. Any one experienced this before? Any help would be appreciated.

    Edit: the car is a 53 plate 1.2
     
  2. rich3001

    rich3001 Active Member

    Joined:
    Mar 9, 2009
    Messages:
    137
    Likes Received:
    1
  3. kidinspace

    kidinspace Service Desk Specialist

    Joined:
    Dec 3, 2008
    Messages:
    1,227
    Likes Received:
    1
    Coil Packs for sure... there is a guide in the FAQ section on how to change them.
    If your search coil packs on the Mk4 Section you'll see lots of threads dexcribing the same symptoms.

    .G.
     
  4. rich3001

    rich3001 Active Member

    Joined:
    Mar 9, 2009
    Messages:
    137
    Likes Received:
    1
    thanks for the reply.
    These coils are costing me a fortune as ive relaced them all 3 times in 2 years. Il give it a go and see if it helps.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice