Dismiss Notice
Hi Guest - time is running out to book your place at our annual get together. Free car stickers included for attendees: Find out more

Common Leon MK2 Problem Log

Discussion in 'Leon Mk2' started by shnazzle, Oct 18, 2011.

  1. ChrisSK

    ChrisSK Full Member

    Joined:
    Jan 25, 2012
    Messages:
    99
    Likes Received:
    0
    Just a little update to the problem I had but did not know at the time of my switch falling into its housing and that is, it turned out I had a slow puncher so this is what gave the warning in the first place.

    I reset the tyre monitor after checking all the tyres finding one was 8 Lbs below its idea pressure however about a month later not having fixed the slow puncher I had the tyre warning again but this time it was only the dashboard icon lit up and nothing on the MDF display. As the car is due to be renewed next week and me being a bit lazy:fool: I just inflated the tyre and reset again however a week later (puncher must be getting worst:whistle:) I had the icon again so I’ve had the tyre fixed.

    What puzzles me is why originally I had a MDF warning and dashboard icon but on the second and third time only the dashboard icon so I wonder if the dashboard warning is just a little nudge and the MDF warning is more serious.
     
  2. Thafussa

    Thafussa Full Member

    Joined:
    Jul 7, 2013
    Messages:
    172
    Likes Received:
    0
    Just a quick random question, what is the recomended gearbox oil weight? I think I hve 80W-120 Valvoline.
    It feels so stiff.
     
  3. Thafussa

    Thafussa Full Member

    Joined:
    Jul 7, 2013
    Messages:
    172
    Likes Received:
    0
    Purchased factory recommended gear oil, the gears now change sooooo much easier.
    Im still putting the car up for-sale.
    TFSI seems to be so noisy. -__-
     
  4. conor13524

    conor13524 Full Member

    Joined:
    Jan 10, 2014
    Messages:
    20
    Likes Received:
    0
    leon fr170 210 remap BMN engine

    I have had a rattle sound coming from the water pump area but need to get under it to have a good look. It has been coming and going and changes through the revs but the water pump is only a year and a half old! whenever I have had the time to have a look the noise has been going away any body with any similare problems or solutions would be appreciated.

    The other little problem which is on cold starts temperature gauge jumps up and down from the bottom to 90 every 5 to 10 seconds it again doesnt always happen and isnt simultaneous to the rattle but not sure if this would be linked to having the EGR blanked off as this can effect the cold starts.
     
  5. JB

    JB JB

    Joined:
    Mar 18, 2008
    Messages:
    149
    Likes Received:
    0
    Hi just had lots trouble with door control unit and now my wing mirrors won't fold in. Dealer said unrelated and motors seized...... Any fixes apart from dealer? Cheers. Fixed rear washer tube using advice on here so thanks
     
  6. mike0105

    mike0105 Senior Member

    Joined:
    Feb 6, 2014
    Messages:
    1,328
    Likes Received:
    1
    Have you tried spraying silicone spray (couple of quid from Halfords)? Revived my dodgy mirrors and they now work perfectly. Good luck with it, hope you get it sorted.
     
  7. mike0105

    mike0105 Senior Member

    Joined:
    Feb 6, 2014
    Messages:
    1,328
    Likes Received:
    1
    Maybe add more soundproofing? Might be cheaper than a new car haha
     
  8. JB

    JB JB

    Joined:
    Mar 18, 2008
    Messages:
    149
    Likes Received:
    0
    Hi anyone know how you get to the motors in the folding mirrors? Thanks
     
  9. FReidiboy

    FReidiboy Full Member

    Joined:
    Jun 25, 2007
    Messages:
    81
    Likes Received:
    0
    Ive got a few issues with my 2012 supercopa.

    Ive got what I would describe as a plasticy rattle/vibration which I think is coming from the dash, more specifically around about the heater vents. It seems to be "revs" related and shows itself lower down the rev range. I dont know if its related but there now seems to be a more metallic rattle that shows itself when the road surface is that bit rougher - not quite sure where in the cabin this is coming from. I have made sure that I have nothing in the glove box or anywhere else that could be causing this!

    And yes, ive got another issue. I get a noise from inside the engine bay that sounds like a squeak/squelch when changing gear. My only thought is that this could be an engine mount.

    Please help as I am going off my head with this!!!
     
  10. GS16LRHP

    GS16LRHP Non fragrant Oil Burner

    Joined:
    Feb 17, 2014
    Messages:
    237
    Likes Received:
    1
    A new one for me: the bulb warning light is intermittent. The "faulty" bulb is the near side tailgate light. I removed the bulb, tested it and it's fine, not blown. Gave the contacts a clean and it was fine for a few days then today the warning light was back on. It usually clears the fault if I switch ignition off and restart the car. Somewhat common, there are threads about it.
    By the way, if anyone wants replacement bulbs get them from Eurocar Parts, for example a light bulb for the tail light (382) are £2.99 at Halfrauds and at ECP just 38p each.
     
  11. Mnb68

    Mnb68 Full Member

    Joined:
    Mar 14, 2015
    Messages:
    43
    Likes Received:
    0
    I've come across quite a few mentions of problems with the loom connecting seatbelt igniters / airbags under the seats have caused repeated airbag light problems but can't find a leon specific how to on the repair . Dealer said cause was stretched wire which makes wonder if it has always been too short
     
  12. STU3Y

    STU3Y Senior Member

    Joined:
    Nov 11, 2013
    Messages:
    1,266
    Likes Received:
    0
    Hot start issue. Car takes longer to start when at temp. Can be any things sometimes not actually a broken or damaged part but more worn. Can be solved by changing the hot start map.
     
  13. stu 157-330

    stu 157-330 Full Member

    Joined:
    Aug 6, 2009
    Messages:
    80
    Likes Received:
    0
    I've had just 2 issues with my 09 plate 2.0 tdi fr.. The airbag light came on which was water ingress in a plug under the front seats, and rear calliper's sticking.. That's been debris getting behind the dust seals which stopped the h/brake holding the disk tight enough

    Twice the car's creeped down the drive..☹️
     
  14. Mackers

    Mackers Part Man, Part Metal

    Joined:
    May 17, 2007
    Messages:
    251
    Likes Received:
    0
    I had this issue, cost me 145 to get diagnosed, they unplugged the ecu and traced the wire back to by the fans in the engine, I replaced the temp sensor in mean time, thinking it was that.
     
  15. James_3

    James_3 Speed Blue

    Joined:
    Sep 1, 2006
    Messages:
    76
    Likes Received:
    0
    I've also had this fault seems like a common issue: http://www.seatcupra.net/forums/showthread.php?t=426770

    Also had air con compressor failure (luckily fixed under warranty as can be up to £1k if not!)
     
  16. wolfmother

    wolfmother Wolfmother

    Joined:
    Aug 17, 2014
    Messages:
    46
    Likes Received:
    0
    Okay so this isn't a common problem but it's definitely an odd one.

    The teeth on the gear which operates the inlet valve had worn out, every time I turned the car off and took the key out it made a fast paced metallic clicking noise as if someone was tapping the engine with a hammer.
    My local VAG dealer replaced the whole unit, they said it was lucky none of the teeth snapped off and decided to have an adventure through the inlet manifold and into the engine.
    I have never heard of anyone else having this issue, this is on a mk2 2.0tdi 140

    Sent from my MotoG3 using Tapatalk
     
  17. Craigp123

    Craigp123 New Member

    Joined:
    May 11, 2016
    Messages:
    1
    Likes Received:
    0
    Leon mk2 turbo issue

    Hi guys,

    Newbie here =) need you help.

    I have a leon mk2 (57plate) 2.0tdi (bkd engine).

    About 7 months ago as i was driving along the A2 my car hit 70 and went into limp mode, i switched off and on again, hit 70 and heard a pop. Car decelerrated rapidly and seemed to die! A few people told me it was the turbo, so left the car in my lock up until i could afford to fix. 7 months later i can afford to fix it, take it to a garage and they quickly diagnose that the turbo is ok but the intercoller to turbo pipe had blown.
    Bought new one, fixed! Drive along A2, hit 70 goes back into limp mode =(. Any ideas? The fault p0299 was coming up (underboost). Drives and boosts fine up to 70mph?

    Its doing my head in grrrr!

    Cheers in advance

    Craig
     
  18. Liverpool Leon

    Liverpool Leon New Member

    Joined:
    Dec 14, 2016
    Messages:
    4
    Likes Received:
    0
    I have a mk2 Leon 2.0tdi 140 had a 180 map done and blew turbo so upgraded with hybrid and now won't boost at all have codes
    Motor for intake manifold flap (V157) no signal P3102

    Motor for intake manifold flap (V157) open or short to ground P3101

    Boost pressure regulation control range not reached P0299

    I have put new hybrid turbo on new intercooler as that was also shot and new boost pipes and still won't pull had a 180BHP map on before I blew standard turbo and how only makes 144nm when I'm scanner and is in limp mode with the codes above help would be very much appreciated I am new on here and don't know how to start own post sorry.
     
  19. a.walker144

    a.walker144 Full Member

    Joined:
    Jan 28, 2016
    Messages:
    31
    Likes Received:
    0
    Did you ever get youra sorted mate ive got same problem
    Thanks

    Sent from my SM-G930F using Tapatalk
     
  20. steveleigh13

    steveleigh13 New Member

    Joined:
    Sep 7, 2017
    Messages:
    7
    Likes Received:
    0
    Anyone know where the speed sensor is on a seat leon FR 1.9 tdi 2005?

    Sent from my E5603 using Tapatalk
     

Share This Page