cupra tdi egr valve?

Discussion in 'Leon Mk1' started by NI3K, Dec 16, 2009.

Tags:
  1. NI3K

    NI3K Full Member

    Joined:
    Nov 19, 2009
    Messages:
    61
    Likes Received:
    0
    any suggestions for websites to source EGR valve from?
    recently had engine management light on which showed up as egr valve, we took it off cleaned it and put it back on but since then engine management coming back on, startup is a bit rough for first couple of seconds and can be a bit jerky at part throttle or when pulling away below 1500rpm. im assuming its still the EGR valve. its an 04 cupra tdi 150. is there a egr replacement which wouldnt make the engine management light come on?
     
  2. Ant FR

    Ant FR Full Member

    Joined:
    Feb 15, 2005
    Messages:
    2,977
    Likes Received:
    0
    can you not put an allards egr replacement pipe on. I hjave one sitting at home to put on my beeza cupra tdi. I too have the jerky pull away on cold starts, so much it sometimes stalls. was told the engien management light will not come on with it.
     
  3. NI3K

    NI3K Full Member

    Joined:
    Nov 19, 2009
    Messages:
    61
    Likes Received:
    0
    from what ive been reading looks like the management light will still come on unless egr is turned down or disabled. anyone near dundee with vag com?
     
  4. GlanzaV

    GlanzaV I start fires!

    Joined:
    Apr 4, 2007
    Messages:
    2,538
    Likes Received:
    1
    Hi!

    If you removed and cleaned the EGR but never blanked off the valve you shouldn't really get an EML...

    I've read a few posts on this and think it may have something with the anti-shudder valve being faulty, which can blow a 10A fuse (in the engine bay fuse box) -- so maybe it's worth checking those to see?
     
  5. NI3K

    NI3K Full Member

    Joined:
    Nov 19, 2009
    Messages:
    61
    Likes Received:
    0
    any ideas which fuse this could be? looked in the handbook but couldnt see anythin obvious for which of the fuses to check
     
  6. GlanzaV

    GlanzaV I start fires!

    Joined:
    Apr 4, 2007
    Messages:
    2,538
    Likes Received:
    1
    Nope... the thread I read a while back just mentioned a 10A fuse in the engine bay, he replaced the fuse cleared the EML and then a few days later the EML came back on, under inspection the fuse had blown again.
     
  7. laawtytdi

    laawtytdi Full Member

    Joined:
    Jan 12, 2009
    Messages:
    45
    Likes Received:
    0
    i've got the problem. it's a fault with the manifold inlet flap motor not opening and then it surges back and blows a fuse. my additional engine heating fuse is blowing 10a think it's number 14.
    Let me know if you get to bottom of it.
    any guides for removing the egr to clean would be appreciated.

    cheers
     
  8. NI3K

    NI3K Full Member

    Joined:
    Nov 19, 2009
    Messages:
    61
    Likes Received:
    0
    got another EGR valve ready to be fitted as a few mechanic friends said that should be all it is so will report back once thats on
     

Share This Page