Dismiss Notice
Hi Guest - time is running out to book your place at our annual get together. Free car stickers included for attendees: Find out more

Faults after Battery Disconnect

Discussion in 'Leon Mk2' started by potter88, Mar 1, 2018.

  1. potter88

    potter88 Full Member

    Joined:
    Jan 1, 2011
    Messages:
    374
    Likes Received:
    0
    Tried starting my car this afternoon but all this cold weather has drained a bit of life from battery. Took battery off and charged up for hr or so. Once reconnected it fired up fine.

    Only thing is it now shows the TPS, Traction and Steering symbol on dash and usually they disappear after a short drive but they didn’t. I disconnected battery again for 5 mins and tried again but no joy and all lights still on.

    Any ideas anyone?


    Sent from my iPhone using Tapatalk
     
  2. Rusty2k

    Rusty2k Full Member

    Joined:
    May 12, 2013
    Messages:
    254
    Likes Received:
    6
    The calibration of the steering angle sensor is lost when the battery is disconnected.

    With the engine running turn the steering lock to lock a few times and it should sort it.
     
  3. potter88

    potter88 Full Member

    Joined:
    Jan 1, 2011
    Messages:
    374
    Likes Received:
    0


    Tried this evening and disconnected battery again and reconnected. Still nothing and stays on.

    I try reset with Carista and still nothing


    Sent from my iPhone using Tapatalk
     
  4. Rusty2k

    Rusty2k Full Member

    Joined:
    May 12, 2013
    Messages:
    254
    Likes Received:
    6
    Okay, what fault codes to you have showing then?
     
  5. potter88

    potter88 Full Member

    Joined:
    Jan 1, 2011
    Messages:
    374
    Likes Received:
    0


    Just comes up with the electronic steering sensor fault (can’t remember code without plugging it back in)


    Sent from my iPhone using Tapatalk
     

Share This Page