Dismiss Notice
Hi Guest. If you're not subscribing to us on YouTube yet, you're missing out on car news and reviews. Subscribe to our channel to get notified when we post new videos.

Heater blowing cold on passenger side

Discussion in 'Leon Mk3 (2012-2020)' started by Wilson9, Feb 10, 2019.

  1. Wilson9

    Wilson9 Active Member

    Joined:
    Oct 12, 2010
    Messages:
    163
    Likes Received:
    3
    i have more than one problem with the car at the moment, just as i tell everyone how reliable my SEAT is.
    The heater weems to be blowing cold air on the passenger side, i have replaced the sensor in the drivers side vent which has made no difference.
    would sticking switches cause this or am i looking at a new heater matrix, the collant level looked a bit low the other day which i have now topped up, if it is a leak at least ill know if the level goes back down.
     
  2. jdubya

    jdubya Active Member

    Joined:
    May 30, 2017
    Messages:
    6
    Likes Received:
    0
    Hi Wilson9, I feel your pain as my Leon blows freezing cold air for no apparent reason??
    I have duel zone climate control and the heating system is quite frankly bloody useless as just as the interior temp gets “cosy” the car decides that it’s time to resemble a fridge to the point that passengers complain about how cold it has now become and I have to turn up the temperature, it gets really hot and then I have to turn it down - never once have I completed either a short or long journey without playing heater temp roulette and it drives me mad!! I have enquired @ my dealer and all I get is that this is normal and a feature of the car but they don’t have to live with it!
    So fed up with this and a couple of other annoying issues that I can’t wait to get rid and get something else.
     
  3. Curtly

    Curtly Active Member

    Joined:
    Jun 5, 2015
    Messages:
    896
    Likes Received:
    18
    I'd try another dealer
     
  4. ryzzey

    ryzzey Active Member

    Joined:
    Jan 18, 2018
    Messages:
    149
    Likes Received:
    38
    I had this with my previous Leon, had the heater matrix replaced. Had the coolant system flushed numerous times and topped up.

    They ended up saying it was the flaps inside the heating control module, one of them was stuck on cold air and wouldn’t move when adjusting the settings. Was quoted over £1000 to take the whole dashboard out and replace the control module. Even though I didn’t have climate control they said the car had the same control module. Needless to say I part exchanged the car for a newer one!
     
  5. CupraGeezer

    CupraGeezer Active Member

    Joined:
    May 11, 2018
    Messages:
    234
    Likes Received:
    93
    Whilst several people have reported problems with the heater matrix, these symptoms are definitely not "normal". Your dealer is fobbing you off, I'm afraid.
     
  6. IbizaNI

    IbizaNI Active Member

    Joined:
    Mar 23, 2015
    Messages:
    157
    Likes Received:
    8
    I have a sort of similar thing going on, "temperature roulette", except mine is as soon as I turn the temperature to 18.5 or above it gets very hot, almost like as though it's at "HI" and when I turn it down below thats cold, it's like an off and on switch for cold or hot air, nothing in between.

    I took it to the dealers and they said "there's no fault codes it's all good", doubt they even tested it just did a diagnostics on it and that's it, needless to say I'm not pleased but I've noticed it seems alright if I put it to "auto" with a/c on so I reckon it's a sensor fault, I just live with it now, seems to predominently happen in the winter, not really noticable in the summer and warmer months.
     
  7. Wilson9

    Wilson9 Active Member

    Joined:
    Oct 12, 2010
    Messages:
    163
    Likes Received:
    3
    Well I lost all temp on a 4hr drive freezing my arse off for the last hour and a half. Going to order up a new matrix and hopefully get it stripped and installed at the weekend.
    I'm that desperate for heat I've been looking at 240v transformers and sticking in an electric radiator.
     
  8. Wilson9

    Wilson9 Active Member

    Joined:
    Oct 12, 2010
    Messages:
    163
    Likes Received:
    3
    Just an update I have changed the matrix and found it to be full of brown crap, it was blocked hence the limited heat when I did get any. After changing it today I seem to have heat out all blowers.
    When changing it out I drained what coolant I could and hoovered the rest out of the matrix pipes with a wet and dry vac. Pulled the hoses off either side of the radiator to drain what I could from there. I had to remove the fan to get the matrix out easier. No leaks so far and coolant is now a nice purple colour again.
    I followed this post https://forums.seatcupra.net/index.php?threads/aircon-and-heater-doesnt-work.432793/
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
     
    #8 Wilson9, Feb 16, 2019
    Last edited: Feb 16, 2019
  9. Wilson9

    Wilson9 Active Member

    Joined:
    Oct 12, 2010
    Messages:
    163
    Likes Received:
    3
    The dents were already there. Its either had a tough life in the factory or someone has previously tried to repair or replace it
     
  10. Nickyzf

    Nickyzf Active Member

    Joined:
    Jan 27, 2019
    Messages:
    18
    Likes Received:
    3
    I have this problem too and the car is only 2 years old and done 12000 miles. Nice and toastie then all of a sudden cold!!! Tried changing set up to no avail
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice