1. Hi Guest. We've recently updated our forum rules. Please take some time to review them. You can read the new rules here
    Dismiss Notice
Dismiss Notice
Hi Guest, stickers are available from our online store.

Infotainment Troubles

Discussion in 'Modifications and Styling' started by Stuart Pearson, Apr 1, 2019.

  1. Stuart Pearson

    Joined:
    Apr 1, 2019
    Messages:
    1
    Likes Received:
    0
    Hi All,

    So, after getting no where with the Seat service in terms of getting my head unit upgraded to the latest firmware version. This being the most annoying part, as they do boost "Check for vehicle safety, software and product enhancements from SEAT’s database (implement with customer's approval)". Last time I checked, a firmware update is a product enhancement. I asked for this many times when I booked the car in so the latter part is true.

    So, I decided to goto the black market of eBay, getting my update file. The seller looked legit and had a few people who said they had no issues with the update. After presenting the car details (VIN, Pictures of the software version of the head unit, part no of the unit and so on) to the seller, they said I was able to upgrade to version 1308. So, I pressed the button and took the plunge. After waiting a long time to get my files, I finally got them today.

    At this point, I was extremely dubious, as installing firmware is a risky business. Firstly, my head unit was on version 0355, which did have a few bugs of which the Apple full link dropping out was the most annoying. I prepped my brand new SD card, that I had bought for this project by extracting the ZIP, which contained version 0674 that I had been given. After doing this, I went to the car and pressed and held the menu button to get to the setup menu. I then went into update area, and selected the SD card and it found the update and presented the list of items that it recons needs updating. Naturally, I then clicked update. As awaiting for around 30 mins, the unit finished updating and come back up ready for use. With the success of this, I got on and did the next update that I had been given 0897. Same process again as above, it updated fine and came back on ready for use. Ok, I felt I was on a roll at this point. So I then went ahead and installed the final version 1308. The process was exactly the same, various screens showing you that it was upgrading and then final script run and then restarted into the SEAT FR boot screen. Unfortunately, the screen has not changed since. I have waiting for this screen to change for 45 mins. I finally gave up and started the car and drove a further 30 minutes back home from work. Unfortunately for me, nothing changed. At this point, worry really set in. I tried hard reset using the volume button and power button and reset the unit with no success. I pulled both fuses out and still nothing. Last thing I tried, which I though would uncover the issue, vagcomming the car.

    This is what I got;

    Monday,01,April,2019,19:17:56:38564
    VCDS Version: Release 18.9.1 (x64) Running on Windows 10 x64
    www.Ross-Tech.com

    Address 5F: Information Electr. Labels: 5F0-035-MIB-HGH2.clb
    Control Module Part Number: 5F0 035 020 G HW: 5F0 035 020
    Component and/or Version: MU-H-ND-EU H50 1308
    Software Coding: 04730001FF0A000011111101008808002F0201D6012001005E
    Work Shop Code: WSC 00049 770 00187
    ASAM Dataset: EV_MUHig6C3Gen2HBAS 001001 (SE37)
    ROD: EV_MUHig6C3Gen2HBAS_AU49.rod
    VCID: 1C3240390F3D63AA21-8048
    1 Fault Found:

    1555 - Check Software Version Management
    B201A 00 [009] - -
    [New feature! Extended UDS fault detail is only supported by current gen. interfaces]
    Confirmed - Tested Since Memory Clear
    Freeze Frame:
    Fault Status: 00000001
    Fault Priority: 6
    Fault Frequency: 1
    Reset counter: 246
    Mileage: 53606 km
    Date: 2019.04.01
    Time: 19:11:54

    Voltage terminal 30: 12.3 V
    Status_Software_Version_Management-module_name: MDUE406/DUE

    Further research of this, unfortunately, pointed to normal behaviour during a software upgrade. This code is uploaded to the SEAT service system to tell them that this unit has had a software upgrade and will clear once it has done.

    So, I am not at a loss. The head unit will not switch off, so I have had to pull the fuses or risk a dead battery in the morning. Contacting the seller has rendered nothing more than re code the unit and everything will be OK. This main zero difference, so I am at a real loss.

    Has anyone else had this issue? I am a seasoned electronic person and have done many mods to VAG group vehicles, but never been in this position. Why have I done it you ask? Well two reasons, one to get things sorted in terms of bugs and secondly to prep the unit for the new digital dash it will be getting. This firmware is the only one that supports this dash, so it was a requirement before I could actually order the dash, trim and fibre cable.

    My car is a 2015 Leon 2.0 150Bhp FR TDi which I had ordered, specified and still own it from factory.

    Thanks for any help!
     
    #1 Stuart Pearson, Apr 1, 2019
    Last edited: Apr 1, 2019

Share This Page