1. Hi Guest. We've recently updated our forum rules. Please take some time to review them. You can read the new rules here
    Dismiss Notice
Dismiss Notice
Hi Guest, stickers are available from our online store.

ISO adapter for ALL facelift models ('04 onwards)

Discussion in 'Mk4 Ibiza FAQ's (6L) 2002-2008' started by NickyJam, Jun 11, 2008.

  1. NickyJam

    NickyJam FR - gone, not forgotten

    Joined:
    Mar 17, 2008
    Messages:
    1,669
    Likes Received:
    0
    Having spoken to both Celsus and CarAudioDirect, tracing back my purchases the products working on mine are:

    1. ISO stalk interface - product no. ASC2638 (NOT CAN-Bus)
    2. Radio interface (corresponding to your radio manufacturer) - in my case this was ASCPIO (Pioneer)

    others have found that this connects2 adaptor works:

    Connects2 unit with code CTSST002 marked from Ray Smith/ Mobiletoys or Dynamics Sounds (make sure you also select the correct patch lead for whichever brand hu you have

    http://www.raysmith.co.uk/Fitting-So...tors/CTSST002/
    http://www.dynamicsounds.co.uk/conn...-leon-altea-stalk-control-adaptor-p-9105.html
     
    #1 NickyJam, Jun 11, 2008
    Last edited: Mar 29, 2010
  2. MrNorma

    Joined:
    Jun 3, 2008
    Messages:
    455
    Likes Received:
    0
    is the confirmed and working on 55plate Ibiza FR? Bought a Connects2 one from ebay and didnt fit.
     
  3. NickyJam

    NickyJam FR - gone, not forgotten

    Joined:
    Mar 17, 2008
    Messages:
    1,669
    Likes Received:
    0
    yes the adaptors at the above link are the ones you want and has been approved by several members :)
     
    #3 NickyJam, Jul 9, 2008
    Last edited: Jul 10, 2008
  4. chris1985

    chris1985 Guest

    i bought the above adapters to connect my jvc avx44 to my controls on my 08 plate ibiza fr.

    all cables fit together but the controls do nothing.

    have i done something wrong?
     
  5. Mr_Dave

    Mr_Dave lnk cr b82rez 2g4!

    Joined:
    Aug 8, 2007
    Messages:
    1,302
    Likes Received:
    2
    How have you got everything connected in?
    iirc just power has to go into the steering wheel control loom and then to the headunit, then the steering wheel controls connecter go into the one that was there standard.

    wasn't a biggie! hope you get it sorted!!
     
  6. chris1985

    chris1985 Guest

    i have the adapter plugged into the 2 connectors on the loom, an iso connector and the steering wheel iso.
    i then have the headunit iso plugged into the last remaining iso on the car loom and then the other on the adapter aswell as having the jack plugged into the oe remote on the headunit.

    hope that makes sense?
     
  7. NickyJam

    NickyJam FR - gone, not forgotten

    Joined:
    Mar 17, 2008
    Messages:
    1,669
    Likes Received:
    0
    I think there is a mixup between 2 adaptors. I received two: 1 from CAD & the other direct from Celsus and the CAD one plugs in correctly but does not work properly whereas the one I have installed now (Celsus) is working perfectly. If you have bought the leads from CAD then get a refund if they canĀ“t find the correct ones.
     
  8. chris1985

    chris1985 Guest

    mines were from CAD but the packaging on the leads was celsus? ill get the part numbers and see if these match
     
  9. NickyJam

    NickyJam FR - gone, not forgotten

    Joined:
    Mar 17, 2008
    Messages:
    1,669
    Likes Received:
    0
    cool...i'm on holiday at the mo but will get the part numbers for you if someone doesn't before me :) but there are a few of us that have our steering controls working just to keep you on our side of this matter
     
  10. mattwoods01

    mattwoods01 Guest

    please will someone confirm that that is the correct adaptor for a 57 plate ibiza fr tdi...
    Chris1985, did you ever manage to get it working on your car?

    Anyone know if it is possible to order this from a high street store such as Halfords?
     
  11. MrNorma

    Joined:
    Jun 3, 2008
    Messages:
    455
    Likes Received:
    0
    Worked perfect on mine!
     
  12. Mr-X

    Mr-X Guest

    Guys,

    I bought one of these from CAD havent got around to fitting it yet one question I have is there is a yellow wire on a red block nothing else what am I ment to do with this?
    My car has steering controls and at the back of the radio there is just the standard iso block whick I have connected to a sony radio and is working fine just looking for some info before I pull it out again to try get the steering controls working.

    Ta
     
  13. Mr-X

    Mr-X Guest

    anyone? i connected it all up and it didn't work but I didn't connect the yellow cable where did you guys connect it too?
     
  14. tkjeeves

    tkjeeves Blue

    Joined:
    Jul 13, 2008
    Messages:
    333
    Likes Received:
    0
    Can anyone confirm the part number for the stalk unit from CAD, i have a nasty feeling that the one i've ordered is not going to work. This the one i ordered from the link provided above.

    The one i got from them is Celsus ASC2638 and says VW Golf 06/02 - 2004 [not CAN]
     
  15. tkjeeves

    tkjeeves Blue

    Joined:
    Jul 13, 2008
    Messages:
    333
    Likes Received:
    0
    ok, this does not work for me, i've connected all up that all fits nicely, but the HU will turn on and the volume will just down down to zero, i've the black wire that is labelled needed to be cut if i have a Pioneer unit, still the same. And working the HU without this, its all fine.

    The HU i got is Pioneer DEH-P700BT

    Any suggestions?
     
  16. chris1985

    chris1985 Guest

    i think you have the same cable i had.

    mines wouldnt work at all and said [non CAN] on the box aswell.

    ive since sold my headunit so cant test it anymore but it sounds like the one they are sending out is the wrong part now.
     
  17. tkjeeves

    tkjeeves Blue

    Joined:
    Jul 13, 2008
    Messages:
    333
    Likes Received:
    0
    oh this really dissapointing, looks like the Connects2 unit is definetly the wrong one also, so what now? anyone know the right kit?
     
  18. halftone

    halftone Active Member

    Joined:
    May 15, 2008
    Messages:
    149
    Likes Received:
    0
    Doesnt work for me either, using an alpine x100.

    The HU turns on, but steering controls do nothing, I found a section in the settings for the stereo that says steering controls, i set it to on, but still nothing.
     
  19. NickyJam

    NickyJam FR - gone, not forgotten

    Joined:
    Mar 17, 2008
    Messages:
    1,669
    Likes Received:
    0
    hey guys. i believe CAD are sending out wrong parts although there are adaptors that DO work as many of us have our steering controls working.

    The stalk adaptor that worked for me came straight from Celsus part no. ASC2638

    http://www.celsusice.co.uk/product_details.aspx?Product_code=ASC2638

    along with the correct aftermarket hu adaptor, in my case it was a Pioneer adaptor product no. ASCPIO
     
    #19 NickyJam, Oct 1, 2008
    Last edited: Oct 1, 2008
  20. halftone

    halftone Active Member

    Joined:
    May 15, 2008
    Messages:
    149
    Likes Received:
    0
    I have the ASC2638, but it says on the package "[not can]" is that right ? As the thread says can bus adapter, i thought it should have been "can" ?

    The other thing that i wondered about was it says;

    Celcus
    Stalk Control

    ASC2638

    VW GOLF
    06/02 > 2004
    [not can]

    Its the bit in bold i thought may be wrong.

    But then again, if yours works Nicky, with the same adapter, why doesnt mine ? I have the correct Alpine part, maybe its the HU ? It has a setting that says Steering, but then all the options are set to FF ??
     

Share This Page