Dismiss Notice
Hi Guest, stickers are now available from our online store. We've also updated our terms and conditions so check them out too.

Issue with front wipers. How to test seat leon wipers?

Discussion in 'Leon Mk2' started by damondavies, Apr 9, 2018.

  1. damondavies

    damondavies Full Member

    Joined:
    Feb 5, 2009
    Messages:
    63
    Likes Received:
    0
    Hi guys,

    I've got an issue with the front wipers not working. Things done so far:

    1) Fuses/relays checked.
    2) Checked connectors to wiper motors

    Is the voltage to the wipers supposed to be constant? I checked with multimeter and it only seems to show 10-14v when I put the + on and then off again?

    Does anyone know how to test these motors to see if I have a dud one?

    Thanks in advance
    Damon
     
  2. RADIOTWO

    RADIOTWO Senior Member

    Joined:
    Mar 6, 2018
    Messages:
    94
    Likes Received:
    12
    Is the bonnet shut correctly !
     
  3. damondavies

    damondavies Full Member

    Joined:
    Feb 5, 2009
    Messages:
    63
    Likes Received:
    0
    Yes, bonnet shut ok.

    I now have both motors out of the car to test, however simply putting voltage to them doesn't work, is there another way to test them?

    Also I have confirmed there's definitely voltage going to both connectors.

    At a loose end here :cry:

    Thanks
    Damon
     
  4. myounus

    myounus Alhambra UK Northwest

    Joined:
    Apr 9, 2018
    Messages:
    11
    Likes Received:
    0
    Hi Damon

    You may simply have a fault that is preventing the BCM from powering them or the motor may be dead. Either way it's best to plug in an OBD2 machine to check. VCDS is the easiest to use.

    Mohammed
     
  5. RADIOTWO

    RADIOTWO Senior Member

    Joined:
    Mar 6, 2018
    Messages:
    94
    Likes Received:
    12
    Hi Damon
    I am not a expert on the Mk2 but you say motors, I assume it has a motor for each wiper but I cannot see both going down so would try the switch or poss a relay
     
  6. damondavies

    damondavies Full Member

    Joined:
    Feb 5, 2009
    Messages:
    63
    Likes Received:
    0
    Thanks both

    It seems the stork is working as the voltage going to the connectors changes.

    Yes there is a motor for each side, I believe the passenger side is the master.

    Does anyone know which relay would be the right one to check?

    Thanks
    D
     
  7. s.chow

    s.chow Member

    Joined:
    Apr 21, 2016
    Messages:
    16
    Likes Received:
    1
    Hi facing the same issue, have you managed to solve it ? Thanks


    Sent from my iPhone using Tapatalk
     

Share This Page