Dismiss Notice
Hi Guest, stickers are available from our online store.

Issue with spec and dealer description

Discussion in 'Alhambra' started by Blackburn1982, Nov 26, 2019.

  1. Blackburn1982

    Joined:
    Nov 26, 2019
    Messages:
    4
    Likes Received:
    0
    Hi guys,

    We've recently taken delivery of a 68 plate Alhambra xcellence (The EZ one though they all seem to have that).

    We picked it up from a Seat dealer up the road after finding it at another branch up in Perth, it was labelled as having a fair bit of kit such as blind spot, lane assist, multi funciton camera and traffic sign recognition along with a couple of usb ports in the rear.

    When the car came and I drove it home it had none of this, I didn't think anything of it at the time with being in a bit of a hurry, it had the newer led internal lights so thought I'd just see if I was missing something when I had some spare time on the evening looking through the menu's.

    From first inspection the car does have the multi function camera on the front (pic attached) but this in itself does nothing obvious. There are no traffic signs shown on the display or anything else, the menu in itself is pretty basic.

    I've emailed the dealer about this and am unsurprisingly awaiting a reply, this is just a quick one to see if any recent owners have had this. The car from what I can tell was built in February 2019, I can't seem a find an actual UK brochure from that time and the current ones have all this stuff as standard so I'm a little confused.

    The dealer took the car off their site when it was reserved, but I managed to get it back from what Google holds on the cached side of it, link for this is below.

    http://webcache.googleusercontent.c...ellence-ez-150-5dr-dsg/2019/ref/arnez-u-21870

    What would you guys typically suggest for something like this, it's been advertised more as something its not?
     

    Attached Files:

  2. Floppus

    Joined:
    Nov 21, 2019
    Messages:
    6
    Likes Received:
    0
    I seem to have a similar problem. Picked up my 69 Xcellence last week. I couldn't find one from stock at any of a huge number of dealerships within 200 miles of my east Midlands location. I was offered one that was due in at the dealer inside 3 weeks..... OK....... Not my first choice of colour but Xcellence, 2.0 TDI DSG.... The spec I wanted..... Had test driven an Xcellence locally very nice. I still have some similar issues. Firstly the brochure does indeed mention a small number of features that fall into the "if fitted" and highlighted *. The major feature that is missing is the "Full link" connection. But in the glove box is a triple usb converter for android and apple devices. Android Auto and Apple Carplay are clearly mentioned in the Infotainment features system. There is only 1 USB socket in the centre box and no Aux socket anywhere. Difficult then to run an Mp3 player and phone connection (unless with B/Tooth). I have over 100 hours of mp3 tunes and the phone already has auto.

    The handbook is totally deficient in dealing with the Parking Assist system with pictures of displays that I do not get. The button with the Po (capital P small steering wheel) is nowhere to be found. The expected rear console USB and 230v sockets are missing. I must have the optical system as the Park Pilot is showing.

    Finally I think I have the 'Self Sealing Tyres'. Other than being mentioned in the brochure I can find no reference to them in the handbook. How do I look after them.

    I have not yet checked everything but wouldn't be surprised at more erratum.
     
  3. Blackburn1982

    Joined:
    Nov 26, 2019
    Messages:
    4
    Likes Received:
    0
    Does your have all the other things on it that mine does not, blind spot , lane assist etc? The more I've read up on it these seem to have been optional systems on the spec at the time which then from maybe May/June 2019 have become standard on it

    The dealer is clueless which is to be expected blaming it on the other franchise but I've pointed out to them they have another car in stock the same as mine advertised with all of these gadgets when it in fact does not, but 've had no response on this and we're awaiting the advert being pulled from the site with the page no longer being valid the cached version from Google has gone too but this was all sent onto the sales person when it was live along with a copy of some of the advertised "spec".

    Regarding the USB in the back mine only has the 230volt socket there in the pull down flap.

    These are all little things I can live without but there will come a point when someone else orders a car in expecting these things only to discover they aren't there and is a little more aggitated by it.

    Lastly mine does have full link on the menu but says it needs to be activated by the dealer, I have a USB in the glove box and one aux input too, I'm assuming you will have the same on yours (pic attached)

    The rest of the car is fine, we all love it, there is just a slight noise coming from the drivers wheel which the technician thinks maybe the tyre itself so thats booked in for next week to have the wheels rotated round. Economy wise for for my first semi-auto it's matching more or less the Insignia I left behind around 35-40mpg around the doors, probably a bit less when wored out properly with these just being taken from the trip computers.
     

    Attached Files:

    • usb.jpg
      usb.jpg
      File size:
      1.6 MB
      Views:
      6
  4. Floppus

    Joined:
    Nov 21, 2019
    Messages:
    6
    Likes Received:
    0
    It seems a total mishmash of stick in what's to hand on the line. This is fine when you get something you weren't expecting but not the other way round. I have come across 'accidental upgrades' a few times. The JIT approach to manufacturing is to blame, but should never occur. I once had a Cortina 1600 S that had a leaking heater. Fortunately I worked at a producer of heat exchangers and pulled an OEM off the ine. At the fitting stage we discovered that the complete heater unit was for a Granada 2.3. Ford, on the back foot, admitted unauthorised substitution.
    To address your specific points, my cars vin number suggests production in Feb 2019 but its arrival at the dealer 3 weeks ago begs the question where has it been. Its date however should match the latest brochure/website/features list.

    Your Alhambra does show differences to mine. I have Lane Assist, Blind spot alarm, Speed Limit display but no alarm. I do not have an aux socket next to the one and only USB input in the centre armrest and no 230v socket on the back of it (suggests wrong console fitted). The touchscreen displays are different to the pics in the handbook which is difficult to read with its small font. I am unable to activate the 'mirror fold on park' feature nor the passenger mirror fold down in reverse I have been unable to understand, therefore reluctant, to risk the Park Assist system. Ambient lighting...?.... In many respects the handbook does not seem to be the right one.

    Perhaps we should arrange a 'did you get what you thought you were getting' for the whole Seat range.
    ...... Watchdog......?
     
  5. Blackburn1982

    Joined:
    Nov 26, 2019
    Messages:
    4
    Likes Received:
    0
    How did you get the manufacture date from the VIN, I've been hunting round for a decent guide on how to de-code them but haven't been able too?
     
  6. Floppus

    Joined:
    Nov 21, 2019
    Messages:
    6
    Likes Received:
    0
  7. Blackburn1982

    Joined:
    Nov 26, 2019
    Messages:
    4
    Likes Received:
    0
    I've only discovered the mirror down on reverse by chance, but you seem you have to flick it to the left mirror on the knob then select reverse and it should go down then revert back to where it was set when you put it back in gear or drive.

    I think, if this hasn't been done since you got it then you need to select the position where you want the mirror yourself when in reverse, then perhaps knock it back into drive and see if it sticks but mine does go down but I can't comment on the other parking feature if thats the auto mark as mine does not have it.

    Meant to reply to this the other day but completly forgot.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice