Dismiss Notice
Hi Guest, stickers are available from our online store.

MAF housing wrong?

Discussion in 'Leon Mk1 (2000-2006)' started by KarlB1, Nov 1, 2017.

  1. KarlB1

    KarlB1 Active Member

    Joined:
    Nov 15, 2012
    Messages:
    326
    Likes Received:
    1
    Hi guys
    I'm trying to trouble shoot an issue I have. Sometimes the car will boost up, dump all boost and then spool up again right away if accelerating from partial throttle. You can hear a lot of sucking (giggidy) from the air filter (I've never owned a 1.8t before so not sure if this is normal).
    You then hear it 'dump' the boost like it would if letting off the throttle before spooling again. I've had a look around and it looks like someone has replaced the N75 already as it has jubilee clips instead of the crimped VW ones. The DV looks original as it has original clips on the hoses so I may change this. One thing I have noticed though is that the MAF housing doesn't seem to meet the air box properly? It's flush, but there's a slight gap on the top part..is this normal? Could this be me loud sucking sound? I did have a new Fiesta ST180 and it made this sucking sound when using an open filter induction kit so this is the first place I looked.[​IMG]

    Sent from my SM-G930F using Tapatalk
     
  2. Cupra Ross

    Cupra Ross Breaks things............

    Joined:
    May 15, 2005
    Messages:
    1,380
    Likes Received:
    1
    N249 doing its thing. Normal, and annoying. Bypass it and remove the ECU's ability to dump your boost air when it doesn't need to.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice