1. Hi Guest. We've recently updated our forum rules. Please take some time to review them. You can read the new rules here
    Dismiss Notice
Dismiss Notice
Hi Guest, stickers are available from our online store.

Misfire under load

Discussion in 'Ibiza Mk2' started by allyboy, Jul 14, 2019.

  1. allyboy

    allyboy Active Member

    Joined:
    Jun 28, 2009
    Messages:
    54
    Likes Received:
    0
    Hello gents, been away for a while as I sold my mk3 20vt. Anyway I got this little beauty for £220. I had to tow it away from the seller as a non start.he told me he changed the dizzy cap and it wouldn't start. I got old dizzy cap off him fitted it and it fired up and cut out, after some tinkering i Checked key and found usual chip had fallen out. I used spare key and it fired up! But it has a misfire under load. I found when pushing car in 4th gear there was a hiss from the spark plugs. I sprayed wd40 and found bubbling up when rocked. So changed the plugs cleaned seats and added hylomar to threads and it stopped the leaks. Only thing is is still misfiring under load. If I rev it gently it won't misfire. I see you guys always say plugs, leads, cap and rotor. But is there anything else common? Cheers
     

    Attached Files:

  2. Copper Cupra

    Copper Cupra Full Member

    Joined:
    Dec 16, 2002
    Messages:
    246
    Likes Received:
    0
    Hi,
    Nice buy... I saw this one on Fbook, a real bargain!
    I had a similar issue with one of my Ibiza GTi 8v's, which also had a cold start problem. The previous owner had been around the houses in swapping out sensors to try and fix it, but failing... then sold it! After some diagnostics from when I bought it, it turned out to be the ECU reading to the throttle body potentiometer not producing a feed. I luckily had a spare ECU to swap out, which fixed this.
    Couple other cheaper things to consider prior - coolant temperature sensor - MAF? Make sure you use genuine parts!
     
  3. allyboy

    allyboy Active Member

    Joined:
    Jun 28, 2009
    Messages:
    54
    Likes Received:
    0
    Thanks for the reply. I sorted it earlier on with a new set of ht leads. Now no misfire at all! Just got to fix all the other problems like shot rear calipers( It did sit for 18 months) blowing exhaust, broken coil spring and new passengers front abs sensor and wiring repair!
     

Share This Page