Dismiss Notice
Hi Guest, stickers are available from our online store.

Overheating problem?

Discussion in 'Alhambra' started by Snowflake, May 14, 2019.

  1. Snowflake

    Snowflake Active Member

    Joined:
    Feb 23, 2013
    Messages:
    35
    Likes Received:
    0
    Got a 2000 1.8T alhambra that im working with.
    Iw had a problem in wintertime getting some heat in the cabin. The analog heat gauge had been sitting on 1/4 and it hardly got above 65c on the digital gauge.
    Took time early past winter and changed the thermostat since logic had it that it was the problem.
    Having changed the thermostat the heat surely got back in the cabin, nice enough.
    But comes this spring im start getting what i think is an overheating problem.
    On trips longer than say 30kilometers the engine temp keeps climbing. The gauge passing mid-point and more and the digital gauge passing the 90´s and towards 100c´s.
    Given the historic problem with the waterpump i suspected that it was the problem, having the past weekend changed this pump, that was fund to be working ok anyways, im comfused over what the problem can be.

    Driving the car to town, not beeing winter, takes having the heating system on full heat to trying to manage the engine heat and over longer trips im having to keep the speed down not to raise the temperature to mutch.
    Also taken notice that when the engine temp is high and i feel the hoose to the radiator the upper is warm, but the lower is cold. I have also flushed the radiator and the flow feels alright.

    So i got some questions.
    Does the analog and digital temp gauge takes its readings from the same sensor?
    What position is the correct and normal for the analoge gauge? 2/4?
    What digital temp is the normal for at engine at normal working temperature?
    Can it be sensor fault, so that the temperature actual is normal?
    What can be causing this problem?

    //Snowflake
     

Share This Page