Pd130 blue smoke when deceleration

Discussion in 'TDi - SEAT Diesel specific topics' started by smokeyjoe, Jun 2, 2017.

  1. smokeyjoe

    smokeyjoe Full Member

    Joined:
    Apr 6, 2009
    Messages:
    103
    Likes Received:
    0
    Hi folks been a wile since i posted on here but I know there's bound to be someone that has had the same problem as me and knows how to fix it

    Here goes I've got a pd130 got turbo dynamics md376 turbo hybrid 150 turbo as far as I know front mount intercooler egr delete full miltek exhaust oil catch can and s2000 filter it's running 2.2bar makes 250bhp and 360lbft at the flywheel it's been on this setup now for 3 years almost and never any trouble until about a week ago or so.

    I noticed that if I'm costing down a hill in gear for like 30seconds once I touch the accelerator there's a cloud of blue smoke out the back it clears after a second and is fine until you coast again it doesn't smoke blue at any other time even on mornings or heavy acceleration just a little black smoke.

    I've checked the car every morning for oil since it started this behaviour and the oil level hasnt dropped it gets serviced every 6/7000miles it currently has 220k miles on it it's never had a camshaft or injectors to my knowledge but idle stabilisation I'd very only +/- 0.5 max and the cam has been inspected and it's in very good shape also.

    Anyone got any ideas its a bit worrying engines are cheap for these I know but it's the hassle changing them.

    Opinions welcome
     
  2. smokeyjoe

    smokeyjoe Full Member

    Joined:
    Apr 6, 2009
    Messages:
    103
    Likes Received:
    0
    Looks like I'm the only one with this issue lol.

    Could it be valve stem oil seals
     
  3. cheshire cat

    cheshire cat Full Member

    Joined:
    Dec 28, 2002
    Messages:
    1,797
    Likes Received:
    0
    catch can is not a cure all when was the system drained/cleaned out
     

Share This Page