Dismiss Notice
Hi Guest, stickers are available from our online store.

Poor cold start and flat spots

Discussion in 'Leon Mk1 (2000-2006)' started by keza1, Feb 16, 2010.

  1. keza1

    keza1 Guest

    I have a 2001 Cupra 1.8 turbo 20v

    In the morning on cold starts it idles fine but if I move within 20 seconds the revs start to flucuates if it wants to stall. If i turn off the igniton and restart it, it's fine. If i sit and lightly rev in for 30 seconds it is also fine. When going along, in 1/2 gear mainly, it seems to have some flat spots. After having some info from the forum I have done the following things.

    1. Changed the temp sensor
    2. 9 months ago it had new plugs and MAF sensor
    3. Checked for leaks but can't see any
    4. Fitted new pipercross filter

    Onlt other things to do now as per info on here is clean the throttle body out. To do this I know it needs to be reset after but I am then carless until it is reset. Can I reset it myself? If I buy a VAGCOM lead, can i download the software? Is it easy to do myself?

    If not, Is it safe to drive until it is reset?

    Could it be anything else?? Only mods are pipercross filter....boost gauge and Forge DV.

    Please help me!
     
  2. Paul B2010

    Paul B2010 Active Member

    Joined:
    Jan 17, 2010
    Messages:
    350
    Likes Received:
    0
    Mine does the same as yours. I havent had time to do anything about it just yet. Just give it short reluctant rev to 2k to wake it up! Ive read a thread which you may or may not have seen. If you explore my posts until you see the "Car doesn't like early mornings" one. Wolvotin has a link for a possible solution within that thread. It was a cheap fix and maybe worth a try. I'm putting up with it for now.
     
  3. keza1

    keza1 Guest

    It's doing my head in. Had the car for 4 months now and only starting doing it last month!! I'm a worrier so want it sorting. I am going to have a good look at it this Saturday morning if it's not raining. Re-check for leaks, check throttle body and plugs.
    I'll keep you updated.
    Got a sneaky feeling the TB will be carbed up
     
  4. keza1

    keza1 Guest

    anymore help??
     
  5. cupra_fr

    cupra_fr Guest

    hi mate, have a look at my "weird rev issue" post.

    I reckon your coil packs have gone maybe..? take it for a short run when warm and then take each one of and see it it smells eggy. other than that it seems like you've changed everything else that could cause it, unless you have a split in a air pipe?
     
  6. kevh

    kevh Leon Cupra 1.8T 03

    Joined:
    Jan 1, 2010
    Messages:
    60
    Likes Received:
    0
    when i first suspected TB just took intake pipe off all looked clean. wasn't until i removed TB from manifold i realized how bad it was.
    clean TB before looking for other solutions best to eliminate one thing at a time i doubt it will be coilpacks as its only when cold and exactly same symptoms as mine had.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice