1. Hi Guest. We've recently updated our forum rules. Please take some time to review them. You can read the new rules here
    Dismiss Notice
Dismiss Notice
Hi Guest, stickers are available from our online store.

Running rough - coilpack?

Discussion in 'Mk1 Leon FAQ's (1M) 2000-2006' started by Phillc, Jul 14, 2009.

  1. Ripraw

    Ripraw Guest

    ok will do, don't want to be doing this again :)
     
  2. hergest

    hergest Newbie

    Joined:
    May 16, 2005
    Messages:
    9
    Likes Received:
    0
    I may have a coil pack issue.

    I recently experienced a very stuttery engine on acceleration; the engine management warning indicator came on. I left it for a couple of hours, and then it seemed to resolve itself. However, I can hear a slight rattling when I accelerate. I thought this was perhaps something physical, eg. exhaust mounting clips loose.

    However, at a recent service they carried out a computerise interrogation which revealed intermittent misfiring fault in cylinder number 3. They carried out further tests which revealed all OK.

    They advised possibly will require a new coil pack for number 3 cylinder if fault returns (£90.24 inc vat fitted), but also advised to replace all coil packs if 1 is required (£242.16 inc vat).

    The garage say they are 90% sure that coil 3 was faulty, but seems okay now. Could this explain a slight rattling noise when accelerating? I don't detect any stuttery engine, seems to be running okay.

    Do I really need to replace all 4 coil packs, or just the one that is likely to be faulty?

    The car is a Cupra FR (2005), 70,800 miles.

    Contemplating changing the coils myself (I'm no mechanic, but the guide made it sound fairly easy).

    Any idea on current prices for coils? Should I go to my service centre to order standard Seat ones?
     
  3. pugaudio

    pugaudio Guest

    DO NOT PAY TO HAVE YOUR COILPACKS CHANGED ! it is so easy just get a flathead screwdriver pop the connector off and pull them out , you can get a set of oem coilpacks for around 70-80£
     
  4. hergest

    hergest Newbie

    Joined:
    May 16, 2005
    Messages:
    9
    Likes Received:
    0
    Thanks. Looks easy enough, but I don't know if this is really my problem.
    It sounds like something is rattling a bit under the hood, only when I accelerate.
    Garage said it could be that one coil is damaged, but don't know which one. Coil 3 was flagged as having a fault when car wasn't running right, but further diagnostic test showed it was working correctly.
     
  5. skinny monkey

    skinny monkey Active Member

    Joined:
    Apr 6, 2014
    Messages:
    51
    Likes Received:
    0
    One of mine died from a bit of boost last week. Diagnosed by removing one plug at a time - was clearly number 2 cylinder as nothing changed when I unplugged it. Turns out the coil was the early type. My LCR was not covered by the recall (checked on the vin). Replaced that one by itself as I was in France and just wanted to get home, but have ordered a full set of 4 genuine ones. I understand part 06A905115D is the latest version? So I'll have one spare in the boot just in case.

    Disconnected the battery for a little bit to clear the fault light as it stayed on (and might be my imagination but it still felt a bit lumpy until I did this)
     
    #245 skinny monkey, Jul 21, 2014
    Last edited: Jul 21, 2014
  6. hergest

    hergest Newbie

    Joined:
    May 16, 2005
    Messages:
    9
    Likes Received:
    0
    I changed coil 3, as the garage said that one was flagged with a warning (but didn't come back when faults were cleared). Car is running okay, but I still hear a metallic rattling noise when starting car cold, or when accelerating over ~2500 rpm. When car is idling, even cruising in 5th gear at low revs, the car sounds fine.

    I tried removing each coilpack (disconnecting the power lead) in turn, and each affected the engine at idle, so I assume I do not have a coil pack issue. I checked the exhaust, and that seems fine.

    Spark plugs were replaced 1-2 years ago.

    Any idea what could be causing this noise?
     
  7. Robbie Romero

    Robbie Romero Active Member

    Joined:
    Mar 4, 2008
    Messages:
    215
    Likes Received:
    0
    Hi,

    Anyone know if there is a 'how to' online, so I can change one of my coil packs, its gonna be number 3, so need to know how to take the bit above it off...
     
  8. Hpi_matrix

    Hpi_matrix Active Member

    Joined:
    Jun 13, 2014
    Messages:
    10
    Likes Received:
    0
    If you cant work out how to remove the engine cover I wouldnt attempt it.
     
    #248 Hpi_matrix, Sep 11, 2014
    Last edited: Sep 11, 2014
  9. yampug

    yampug Active Member

    Joined:
    Nov 4, 2014
    Messages:
    1
    Likes Received:
    0
    has any one tried ngk coil packs?
     
  10. Miss Chief

    Miss Chief Active Member

    Joined:
    Jun 4, 2011
    Messages:
    125
    Likes Received:
    0
    Could a faulty coil pack cause very rough running on startup but if I let it idle for a couple of minutes to warm the engine a little it then drives, accelerates and boosts fine? Leon Cupra 180, 2004.
     
  11. Bigjohn84

    Bigjohn84 Intagram / johnyoung84

    Joined:
    May 5, 2015
    Messages:
    2,330
    Likes Received:
    1
    Miss chief your cool pack may be on the way out but only way to see is if you change them, take one out at a time and start your car you will find the one possibly two that are knackerd If your cool pack fails you no about it, it's constant juddering and rumbling noise, u can't pick up any speed atol, mines went befour and I got them out a Passat 2.0T I also carry two spare in my boot just in case.
     
    #251 Bigjohn84, May 18, 2015
    Last edited: May 18, 2015
  12. Bigjohn84

    Bigjohn84 Intagram / johnyoung84

    Joined:
    May 5, 2015
    Messages:
    2,330
    Likes Received:
    1
    Robbie you just take ur engine cover of and unplug the coil pack then pull it out, plug 4 you will have to take a plastic case of top first 3 Alan key bolts. While ur there I'd pull ur spark plugs out also and clean them, make sure the gaps correct and not bent in. Make sure there's no oil on ur spark plugs also, Hope this help.
     
  13. sas2003

    sas2003 Active Member

    Joined:
    Feb 8, 2015
    Messages:
    8
    Likes Received:
    0
    Moved post
     
    #253 sas2003, Oct 21, 2015
    Last edited: Oct 22, 2015
  14. Chris D

    Chris D 1.8 20v

    Joined:
    Apr 30, 2016
    Messages:
    19
    Likes Received:
    0
    Struggles to start

    Hi guys, every time I try to start my car it really struggles to fire up. I have to pump the accelerator abit to get it started, but once its started it idles perfectly and drives spot on. I have changed my CTS, I've had it plugged in and no fault codes appear, could it be a simple case of change my battery? As the light appears for a couple of seconds after it fires up then goes! I've been and had the starter motor, alternator and battery checked and they are all apparently okay though..? Any help or advice would be greatly appreciated!
     
  15. Liam180cupra

    Liam180cupra Active Member

    Joined:
    Jan 27, 2016
    Messages:
    113
    Likes Received:
    0
    Get to andrew pages if you have one only £28 each for bosch ignition coils
     

Share This Page