Dismiss Notice
Hi Guest - time is running out to book your place at our annual get together. Free car stickers included for attendees: Find out more

**Solved** Drivers Side Electrics

Discussion in 'Ibiza Mk4' started by dmcar02, Nov 11, 2017.

  1. dmcar02

    dmcar02 Full Member

    Joined:
    Apr 9, 2009
    Messages:
    29
    Likes Received:
    0
    Hi all,

    Bit of an issue. None of the switches are working on my door, (Electric windows and Central locking). They aren't illuminating even when the lights are on. Passenger side is fine, window button works and illuminates.

    Also, when I put the parking light on for the driver side, it doesn't work. The Lights-on buzzer still works, however neither the front or rear parking light comes on. Again, passenger side works fine.

    Is there some sort of fuse or relay which controls the electrics of the car for both sides? It's as if the right side of the car isn't working.
     
    #1 dmcar02, Nov 11, 2017
    Last edited: Dec 13, 2017
  2. dmcar02

    dmcar02 Full Member

    Joined:
    Apr 9, 2009
    Messages:
    29
    Likes Received:
    0
    Slight update,

    I got the parking light fixed, turns out it was the fuse.

    The door is still dead. Speaker is working, as is the tweeter.

    Any ideas are most welcome.
     
  3. RUM4MO

    RUM4MO Senior Member

    Joined:
    Jun 4, 2008
    Messages:
    4,466
    Likes Received:
    10
    I would think your problem lies within the door hinge area, ie there are a lot of wiring passing through from the car into the door, draw back the wiring protection "bellows" and see if any broken wire comes into view?
     
  4. dmcar02

    dmcar02 Full Member

    Joined:
    Apr 9, 2009
    Messages:
    29
    Likes Received:
    0
    Just to follow this up - it turned out to be the module fitted to the drivers side motor. 19 quid for a replacement, and back to normal now!
     
  5. RUM4MO

    RUM4MO Senior Member

    Joined:
    Jun 4, 2008
    Messages:
    4,466
    Likes Received:
    10
    Excellent! It is always good when someone posts back after sorting something and says exactly what fixed it.
     

Share This Page