Dismiss Notice
Hi Guest, stickers are available from our online store.

Very cold days sets off oil light

Discussion in 'Leon Mk1 (2000-2006)' started by daveyonthemove, Feb 17, 2008.

  1. Mitchy

    Mitchy TTRS

    Joined:
    Oct 12, 2004
    Messages:
    2,310
    Likes Received:
    0
    Personally never read a thread where it has come back after an expansion tank replace. This is the dealers fix for the problem also. Ive had trouble free now over the last 3 winters:funk:

    For the sake of £12, i'd say it was worth it :) Early morning beeps got right on my nerves:censored:
     
  2. daveyonthemove

    daveyonthemove Smile if you like SEAT's

    Joined:
    May 14, 2006
    Messages:
    1,519
    Likes Received:
    0
    well i may be guilty of a bad search due to the fact i searched the wrong area, but if you re-read my first post (the one you originally had a smart answer for) you'd see that i'm not able to get to a dealers very easily, so i was merely seeking info on the problem and what may sort it.
    A couple of posts after yours gave the info i needed and i have sorted it for now. The problem may return, it may not, but with the info i was given i able to identify that its not an big issue that needs immediate attention.
    I'm not prepared to spend £12 on a part that my warranty will cover, so when i get a few days off it will be booked in. For now i'll carry on as i am.
     
  3. UncleFester

    UncleFester Grumpier by the day!

    Joined:
    Apr 30, 2006
    Messages:
    4,764
    Likes Received:
    0
    Maybe the bulb is blown, maybe the Tdi has a different sensor or maybe it's just weird ....... i would be slightly concerned about a system that goes straight from OK to RED with no warning in between.

    I wonder is there a VAGCOM warning light cycle facility where you can cycle each warning light to verify operation?
     
  4. jonjay

    jonjay 50 Years of 911

    Joined:
    Jun 27, 2005
    Messages:
    5,843
    Likes Received:
    1
    EXACTLY the same happened to me hence i thought it was an oil problem. When i check the oil it was congealed on the bottom of the stick. Left the engine running (warmed up) then drove and got AMD to check it out as I thought it cant be the oil as it was fine a month a go. They said the congealed theory and that condensation when very cold gets on some sensor hence the beeps.

    As for the VAGCOM i had it done that day and nothing came up...
     
  5. daveyonthemove

    daveyonthemove Smile if you like SEAT's

    Joined:
    May 14, 2006
    Messages:
    1,519
    Likes Received:
    0
    I've vagcom'ed mine with the RED coolant light flashing, but it never gave any codes :shrug:
    All sorted now though.
     
  6. traumapat

    traumapat Leon Cupra IHI

    Joined:
    Jul 24, 2005
    Messages:
    5,930
    Likes Received:
    3
    i think the pre ignition lights on the dash are a test it show all warning lamps illuminate.

    my handbook mentions a flashing red or solid red oil lamp and 3 beeps above 1.5k as a warning. dosnt mention amber but this is a 01 petrol.
     
  7. andycupra

    andycupra status subject to change

    Joined:
    Aug 18, 2003
    Messages:
    8,106
    Likes Received:
    48
    When the red light flashes and you get 3 beeps this is the coolant low level issue. That is, the sensor is reading that the coolant level is low. However due to the issues seen with the coolant sensor this reading may be incorrect.


    Well i can only assume this is because they have lost the will to write about it.
    I will state now, that in my personal experience replacing the coolant expansion tank and sensor fixed the problem temporarily. I came back 12 months later :) or should that be :(
    But it would seem that not all cars are effected by this issue, therefore replacing it may mean you are one of the lucky ones where it works ok!
     
  8. jonjay

    jonjay 50 Years of 911

    Joined:
    Jun 27, 2005
    Messages:
    5,843
    Likes Received:
    1
    Thats exactly what i think it is then...
     
  9. Timmyboy

    Timmyboy Former Cupra Owner

    Joined:
    Aug 27, 2005
    Messages:
    108
    Likes Received:
    0
    Ok, ignore this.
     
    #69 Timmyboy, Feb 19, 2008
    Last edited: Feb 19, 2008
  10. dajackos

    dajackos Guest

    Water level Beep

    I have the same prob on cold days, beeps 3 times and red light on display. Turn car off and back on and light goes and no beep. I will try fiddling with connectors b 4 i scrape the prongs and see if it sorts it. I thought it could be down to a higher electrical resistance in cold weather giving false reading for coolant level sensor.
     
  11. andycupra

    andycupra status subject to change

    Joined:
    Aug 18, 2003
    Messages:
    8,106
    Likes Received:
    48
    that would be great! if posible try taking sensor lead off and replace it and test.
    then next would be simple wiggling the prongs (no scraping..)

    lets hope the weather stays cold to be a consistent check :)
     
  12. scarface

    scarface Full Member

    Joined:
    Oct 27, 2005
    Messages:
    615
    Likes Received:
    0
    that is quality! i had the prob with the temp light this morn!
     
  13. Timmyboy

    Timmyboy Former Cupra Owner

    Joined:
    Aug 27, 2005
    Messages:
    108
    Likes Received:
    0
    Yup - as soon as the temperature drops you'll see a load of these beep threads springing up :)
     
  14. TheWizard

    TheWizard Guest

    Useful thread thanks! I have this problem as well. Though decided the best approach was to ignore it :)

    It went away this summer, but I will give the prongs a scrape this weekend before the winter sets in!
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice